Some views under the Privacy Requests tab are failing to load for customers in the EU region.
Incident Report for Transcend
Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 10:01 PDT
Identified
A few views under the Privacy Requests tab are failing to load. We have determined the root cause of the issue and are working on deploying the fix.
Posted Oct 10, 2023 - 23:45 PDT
This incident affected: Admin Dashboard.