Increased Latency in EU-Hosted Region

Incident Report for Transcend

Resolved

This issue has been resolved, with latency returning to normal levels since 1:28 PM PDT.
Posted Apr 04, 2025 - 14:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2025 - 13:28 PDT

Identified

Our systems in the EU are under increased load and we are scaling up to meet demand.
Posted Apr 04, 2025 - 13:11 PDT

Investigating

We are currently investigating this issue.
Posted Apr 04, 2025 - 12:24 PDT
This incident affected: Admin Dashboard, Backend API, and Multi-Tenant Sombra.