Admin Dashboard failing to load

Incident Report for Transcend

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 06:21 PDT

Update

The Admin Dashboard is fully operational. Pages no longer hang in a loading state.
Posted Jul 25, 2025 - 06:20 PDT

Update

The Admin Dashboard is operational. Some pages for some organizations remain in the loading state indefinitely. Interacting with the navigational sidebar can prompt pages to load. We are continuing to investigate this issue.
Posted Jul 25, 2025 - 05:54 PDT

Update

We are continuing to investigate this issue.
Posted Jul 25, 2025 - 05:51 PDT

Update

We are continuing to investigate this issue.
Posted Jul 25, 2025 - 05:27 PDT

Update

We are continuing to investigate this issue.
Posted Jul 25, 2025 - 05:23 PDT

Investigating

We are currently investigating performance issues with our Admin Dashboard
Posted Jul 25, 2025 - 05:23 PDT
This incident affected: Admin Dashboard.