Backend downtime
Incident Report for Transcend
Resolved
This incident appears resolved with the upstream AWS CloudFront service.

This appears to have affected users primarily in us-east-1 accessing AWS CloudFront content: https://news.ycombinator.com/item?id=36775816
Posted Jul 18, 2023 - 10:19 PDT
Update
Our backend has appeared healthy consistently. Our frontend is experiencing unrelated issues caused by upstream downtime in certain edge locations with AWS CloudFront. This appears consistent with what we are seeing on the AWS page of https://downdetector.com/status/aws-amazon-web-services/
Posted Jul 18, 2023 - 10:04 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 18, 2023 - 09:55 PDT
Update
The backend is continuing to look healthy in recent tests
Posted Jul 18, 2023 - 09:55 PDT
Monitoring
We have confirmed that the API is responding again for users. We are continuing to monitor the application for overall health
Posted Jul 18, 2023 - 09:49 PDT
Identified
We have noticed an issue with our backend API where requests are failing to complete. We have identified the issue and are rolling out a fix.
Posted Jul 18, 2023 - 09:41 PDT
This incident affected: Admin Dashboard and Backend API.