The DSR backlog is now down to normal levels. Incoming DSRs should process as per usual.
Posted Apr 25, 2025 - 11:59 PDT
Monitoring
We have successfully scaled our infrastructure up to accommodate the increased API demand in the EU region.
Backend performance is now healthy. However, the secondary effect of the recent backend performance degradation is that a backlog of DSRs have accrued. The backlog is actively being processed now.
We will keep this incident open until that DSR processing pipeline returns to normal levels.
Posted Apr 25, 2025 - 09:23 PDT
Identified
We have identified a fix and are scaling our infrastructure to accommodate extreme API demand.
The first-order impact to load times in the Admin Dashboard were fixed overnight and we are monitoring results this morning (Pacific Time).
The second-order impact on DSR processing times is our focus this morning, and infrastructure scaling is underway.
Posted Apr 25, 2025 - 06:37 PDT
Investigating
We are currently investigating performance issues with our backend API.